Tải bản đầy đủ

ĐỀ CƯƠNG GIAO THỨC TCPIP

1.Khái niệm địa chỉ MAC (địa chỉ vật lý), cách thiết bị xác định địa chỉ MAC khi biết địa chỉ IP
của thiết bị khác?
*Khái niệm: Địa chỉ MAC là địa chỉ vật lý hay còn gọi là số nhận dạng (Identification number) của thiết
bị mạng. Mỗi thiết bị (cart mạng, modem, router …) được nhà sản xuất chỉ định và gán sẵn 1 địa chỉ
nhất định. Nó có chiều dài 48 bit được biểu diễn bằng 12 số hexa, được viết theo dạng:
MM:MM:MM:SS:SS:SS hay MM-MM-MM-SS-SS-SS. Trong đó 24 bit đầu là mã số của nhà sản xuất,
24 bit sau là số seri của từng cart mạng được NSX gán.
*Nguyên tắc tìm địa chỉ MAC khi biết địa chỉ IP :
-Khi máy A (129.1.1.1) muốn giải địa chỉ IP (129.1.1.4) là IB, nó phát đi đến mỗi máy khác một gói
dữ liệu đặc biệt để hỏi xem máy nào có địa chỉ IP là IB, thì trả lời bằng địa chỉ vật lý, PB. Tất cả
các máy, bao gồm cả B (129.1.1.4) đều nhận được yêu cầu này, nhưng chỉ có máy B nhận ra địa chỉ
của nó và gửi lại lời đáp có bao gồm địa chỉ vật lý của nó. Khi A nhận được lời đáp, nó sử dụng địa
chỉ vật lý này (PB) để gửi dữ liệu trực tiếp tới B. Song song với quá trình đó là những máy nào chưa
có bộ thông tin về đia chỉ vật lý của A, địa chỉ ip của A sẽ lưu lại thông tin này vào bảng lưu trữ địa
chỉ của nó.

.H

.P

N


11.Định tuyến là gì? Hãy phân loại các phương thức định tuyến? Bảng định tuyến của router
bao gồm những thông tin gì?* Khái niệm: Định tuyến là quá trình xác định đường đi tốt nhất trên
một mạng máy tính để gói tin tới được đích theo một số thủ tục nhất định nào đó thông qua các nút
trung gian là các bộ định tuyến router. Thông tin về những con đường này có thể được cập nhật tự
động từ các router khác hoặc là do người quản trị mạng chỉ định cho router.

A

O

* Phân loại: Định tuyến được phân chia thành 2 loại cơ bản: Định tuyến tĩnh: Việc xây dựng bảng
định tuyến của router được thực hiện bằng tay bởi người quản trị.

N

- Định tuyến động: Việc xây dựng và duy trì trạng thái của bảng định tuyến được thực hiện tự động
bởi router.
* Bảng định tuyến:- Địa chỉ IP đích (destination IP): Địa chỉ này có thể là địa chỉ của một host cụ
thể, hoặc là một địa chỉ của một mạng. Nếu là địa chỉ host, entry này sẽ có host-ID khác 0 để nhận
diện một host. Nếu là địa chỉ mạng, phần host-ID = 0.
- Địa chỉ IP của next-hop router (next-hop IP), hoặc địa chỉ của một mạng kết nối trực tiếp (directly
connected IP address): Là địa chỉ của đích đến tiếp theo (router) có thể chuyển tiếp gói tin đến đích.
- Network interface: Là cổng của router được sử dụng để gửi gói tin đến next-hop.
- Cờ (flags): Cho biết nguồn cập nhật của tuyến (route). Ví dụ: S – Static Route, C – Connected
Route, O – OSPF Route…
- Metric: Là thông tin về metric của một tuyến đường, thể hiện “khoảng cách” từ router hiện tại đến
destination IP. Giá trị này chỉ có ý nghĩa so sánh khi các route sử dụng cùng một giao thức định
tuyến.
- Administrative Distance (AD): Tham số ưu tiên mà người quản trị đặt cho các tuyến trong bảng
định tuyến, được gán cho các giao thức. Nếu tuyến được cập nhật từ giao thức, nó sẽ mang giá trị
AD của giao thức đó. Giá trị này nằm trong khoảng từ 0 đến 255, càng bé càng ưu tiên. 255 có
nghĩa là tuyến không bao giờ được sử dụng.


4.Hãy trình bày quá trình bắt tay 3 bước (Three-way handshaking) thiết lập kết nối của giao
thức TCP. Vẽ hình minh họa.

.P

N

Bước 1: Host A gửi cho B một gói tin có cờ SYN được bật lên, với số thứ tự được đánh là x
Bước 2:Host B nhận được gói tin thì B gửi lại gói tin có cờ SYN được bật lên, kèm theo đó là cờ
ACK để xác nhận.ACK = x+1 nghĩa là: Máy A, tôi đã nhận được gói tin có SEQ = x, tôi mong muốn
nhận thêm gói tin có SEQ = x+1. Khi gửi gói tin đi thì nó đánh số thứ tự SEQ =y
Bước 3: Sau khi kết nối đã được thiết lập thì A gửi tin để đáp ứng nhu cầu của B. Gói tin được đánh
số SEQ =x+1 để đáp ứng nhu cầu của B. ACK = y+1dùng để báo là đã nhận được gói tin có SEQ = y.
Chỉ có cờ ACK được bật lên bởi gói tin bước 3 được dùng để báo nhận cho gói tin bước 2
20.Các tính chất của chuyển phát tin cậy.

.H

O

Sự giao tiếp giữa các chương trình ứng dụng và dịch vụ phát chuyển tin cậy TCP/IP có thể đặc
trưng hoá bởi 5 khía cạnh:

N

A

* Định hướng stream. Khi hai chương trình ứng dụng (các tiến trình của người sử dụng) truyền
những khối lượng lớn dữ liệu, chúng ta xem dữ liệu như một chuỗi các bit, được chia thành các byte
8 bit, mà chúng ta thường gọi là byte. Dịch vụ phát chuyển stream trên máy đích chuyển đến nơi
nhận một cách chính xác cùng một chuỗi các byte mà máy gửi chuyển nó đi.
* Kết nối mạch ảo. Thực hiện việc truyền stream cũng tương tự như thực hiện một cuộc gọi điện
thoại. Trước khi việc truyền có thể bắt đầu, cả hai chương trình ứng dụng gửi và chương trình ứng
dụng nhận tương tác với các hệ điều hành của chúng, thông báo chúng về mong muốn có được việc
truyền stream.
* Việc truyền có vùng đệm. Các chương trình ứng dụng gửi một dòng dữ liệu qua mạch ảo bằng
cách lập lại việc chuyển các byte dữ liệu đến phần mềm giao thức. Khi truyền dữ liệu, mỗi chương
trình ứng dụng sử dụng bất kỳ kích thước đơn vị truyền nào nó thấy thuận tiện, mà có thể chỉ bằng
một byte.
* Stream không có cấu trúc. Dịch vụ TCP/IP stream không xác định các dòng dữ liệu có cấu trúc.
Các chương trình ứng dụng sử dụng dịch vụ stream phải hiểu nội dúngtream và thông nhất với nhau
về định dạng stream trước khi khởi động việc kết nối.
* Kết nối hai chiều. Các kết nối được cung cấp bởi dịch vụ TCP/IP stream cho phép truyền dữ liệu
đồng thời từ cả hai chiều. Cách kết nối này được gọi là full-duplex (song công).


2.Hãy trình bày chức năng của giao thức ICMP (Internet Control Message Protocol) . Có mấy
loại thông điệp ICMP? Hãy mô tả mục đích của từng loại thông điệp đó. Mô tả nguyên lý hoạt
động của lệnh PING dựa trên ICMP và cấu trúc các thông điệp mà nó sử dụng. Định dạng
thông báo ICMP báo đích không đến được? Nguyên lý xử lý khi gặp nghẽn mạng của giao
thức ICMP?
* Chức năng: - ICMP là một giao thức điều khiển của mức IP, được dùng để trao đổi các thông tin
điều khiển dòng số liệu, thông báo lỗi và các thông tin trạng thái khác của bộ giao thức TCP/IP, một
số chức năng tiêu biểu của nó là : + Điều khiển lưu lượng dữ liệu (Flow control): Khi các gói dữ
liệu đến quá nhanh, thiết bị đích hoặc thiết bị định tuyến ở giữa sẽ gửi một thông điệp ICMP trở lại
thiết bị gửi, yêu cầu thiết bị gửi tạm thời ngùng việc gửi dữ liệu.
+ Thông báo lỗi: Trong trường hợp địa chỉ đích không tới được thì hệ thống sẽ gửi một thông báo
lỗi: “Destination Unreachable ”.
+ Định hướng lại các tuyến đường: Một thiết bị định tuyến sẽ gửi một thông điệp ICMP “định tuyến
lại” (Redirect Router) để thông báo với một trạm là nên dùng thiết bị định tuyến khác để tới thiết bị
đích. Thông điệp này có thể chỉ được dùng khi trạm nguồn ở trên cùng một mạng với cả hai thiết bị
định tuyến

.P

* Các loại thông điệp ICMP

N

+ Kiểm tra các mạng ở xa: Một trạm có thể gửi một thông điệp ICMP “Echo” để kiểm tra xem một
trạm có hoạt động hay không.

N

A

O

.H

1.kiểm tra khản năng đến đích và trạng thái của đích(ping ICMP) 2.làm nguôi nguồn phát khi có sự
cố nghẽn mạng(source quench) 3. yêu cầu thay đổi định tuyến của bộ định tuyến.4. nhận biết vòng
kín hoặc định tuyến quá dài.5. báo lỗi có vấn đề tham số của datagram 6. đồng bộ đồng hồ và ước
lượng thời gian. 7. tìm mặt nạ mạng con. 8. tìm ra bộ định tuyến. 9. yêu cầu bộ định tuyến cấp thong
tin tức thì. 10. báo lỗi các đích không đến được.
*Nguyên lý hoạt động: - Một trong những công cụ tìm lỗi thường được sử dụng nhất liên quan đến
các thông điệp “echo request” và “echo reply” của ICMP. Một máy tính hoặc bộ định tuyến gửi một
thông điệp ICMP “echo request” tới một đích cụ thể.Máy nào nhận đc 1 “echo request” sẽ tạo ra 1
“echo reply” và trả nó về nơi gửi đầu.
- Lời yêu cầu (echo request) có bao gồm một vùng dữ liệu, tuy chọn; lời đáp (echo reply) bao gồm
một phiên bản của dữ liệu được gửi trong lời yêu cầu. “Echo request” và “echo reply” tương ứng có
thể được dùng để kiểm tra xem một máy đích là có thể đến được hay không và có đáp lời không.
- Trên nhiều hệ thống,lệnh thực hiện việc gủi thông điệp ICMP. “echo request” có tên là PING.Các
phiên bản phức tạp của PING gửi 1 loạt datagram bị mất,thậm chí cả thời gian đáp ứng.Chúng ta
cho phép nguwoif sử dụng xác định độ dài của dữ liệu đc gửi và khoảng thời gian giữa các lần gửi.
- Khuông dạng của thông điệp ICMP Echo Request và Echo Reply bao gồm các phân Header chuẩn
ban đầu và cộng thêm vùng có tên OPTIONAL DATA là một vùng có độ dài thay đổi để chứa dữ
liệu sẽ trả về cho nơi gửi. Một "echo reply" luôn luôn trả về 1 cách chính xác cùng 1 dữ liệu nó nhận
được từ "echo request".
*Cấu trúc thông điệp


*Cấu trúc thông điệp
+) Khuôn dạng thông điệp ICMP echo request và echo reply bao gồm các phần Header chuẩn ban
đầu và cộng thêm vùng có tên OPTIONAL DATA là một vùng có độ dài thay đổi để chứa dữ liệu sẽ
được trả về cho nơi gửi. Một “echo reply” luôn luôn trả về một cách chính xác cùng một dữ liệu như
nó nhận được từ “echo request” +) Các vùng IDENTIFIER và SEQUENCE NUMBER được nơi gửi
sử dụng để so sánh giữa lời yêu cầu và lời đáp. Giá trị của vùng gửi TYPE để xác định thông điệp là
một yêu cầu (8) hay lời đáp (0).
*Thông điệp ICMP báo lỗi các đích không đến được Khi một bộ định tuyến không thể truyền hay
phát chuyển một IP datagram, nó gửi một thông báo “đích không thể đến“ ngược trở về nguồn ban
đầu, thông qua định dạng của phần Data Option như hình sau:

O

.H

.P

N
N

A

Vùng CODE trong một thông điệp “đích không thể đến” chưa
một số nguyên để mô tả thêm về vấn đề. Các giá trị đó là: 0: Network unreachable 1: Host
unreachable 2:Protocol unreachable 3:Port unreachable 4:Fragmentation needed but the Do
Not Fragment bit was set 5:Source route failed 6:Destination network unknown 7:Destination
host unknown 8:Source host isolated (obsolete) 9:Destination network administratively
prohibited 10:Destination host administratively prohibited 11:Network unreachalbe for this
type of service 12:Host uncreachable for this type of service 13:Communication
administratively prohibited by filtering 14:Host precedence violation 15:Precedence cutoff in
effect
* Nguyên lý xử lý khi gặp nghẽn mạng của giao thức ICMP?
- Khi datagram đến quá nhanh mà máy tính hoặc bộ định tuyến không xử lý kịp, chúng sẽ được sắp
vào hàng đợi (bộ nhớ tạm thời). Nếu các datagram này là một phần một đoạn dữ liệu nhỏ, vùng đệm
này có thể giải quyết được vấn đề. Nhưng nếu dữ liệu vẫn được gửi liên tục, sẽ làm cạn kiệt vùng
nhớ đệm, máy tính hoặc bộ định tuyến sẽ phải hủy bỏ những datagram đến sau. Một máy tính sử
dụng thông điệp ICMP “source quench” để thông báo sự nghẽn mạch cho nguồn ban đầu. Một
thông điệp “source quench” là một yêu cầu đối với nguồn ban đầu để giảm bớt cường độ truyền
datagram. Khi một máy nhận được thông điệp “source quench” cho máy đích D, nó sẽ giảm dần
cường độ gửi datagram đến máy D cho tới khi nó hết nhận được thông điệp “source quench”, sau đó
nó sẽ lại tăng dần cường độ gửi miễn sao không còn nhận được các yêu cầu “source quench”.


3.Trình bày chức năng và Nguyên lý hoạt động của giao thức ARP,cấu trúc thông điệp ARP
request.
*Chức năng: ARP được sử dụng để từ một địa chỉ mạng (ví dụ một địa chỉ IPv4) tìm ra địa chỉ vật
lý như một địa chỉ Ethernet (địa chỉ MAC), hay còn có thể nói là phân giải địa chỉ IP sang địa chỉ
máy. ARP đã được thực hiện với nhiều kết hợp của công nghệ mạng và tầng liên kết dữ liệu, như
IPv4, Chaosnet,..
* Nguyên lí hoạt động của giao thức ARP.- Khi máy A có địa chỉ IP là IA và địa chỉ MAC là PA
cần trao đổi dữ liệu với máy B có địa chỉ IP là IB và địa chỉ MAC là PB . Giả sử A chưa biết địa chỉ
MAC của B mà chỉ biết địa chỉ IB .giao thức ARP hoạt động như sau:+ B1: A sẽ gửi thông điệp
quảng bá đến tất cả thiết bị nằm cùng mạng với nội dung thông điệp có dạng "Who is IB?"
+ B2: tất cả các thiết bị cùng mạng với A sẽ nhận được thông điệp trên. Nếu không có IB nó sẽ
discard thông điệp.máy B nhận thấy đó là địa chỉ của mình thì sẽ gửi lại cho A địa chỉ MAC của
mình.
+ B3: A lưu thông tin PB vào bảng ARP của mình sau đó tiến hành truyền tin.Khi A truyền thông
điệp nếu thiết bị nào chưa có địa chỉ của A nó sẽ lưu địa chỉ IP và địa chỉ MAC của A vào bảng
ARP của
* Cấu trúc thông điệp ARP Request

N

Protocol

Operation

O

Length

.H

Hardware
length

Protocol type

.P

Hardware type

Send hardware address

N

A

Send hardware address

Send ip address

Send ip address
target hardware address
Target ip address
Không giống như hầu hết các giao thức, dữ liệu trong gói ARP không có phần đầu (header) được định
dạng cố định. Các vùng có ý nghĩa như sau :+ Hardware type : xác định kiểu của bộ giao tiếp phần
cứng mà máy gửi đang cần biết , với giá trị 1 dành cho Ethernet.
+ Protocol type : xác định kiểu của giao thức địa chỉ cấp cao mà máy gửi cung cấp, nó có giá trị
080016 dành cho địa chỉ ip.
+ operation : xác định kiểu thông điệp là 1 trong các loại sau : thông điệp này là 1 yêu cầu ARP .
thông điệp này là 1 lời đáp . thông điệp này là một thông điệp RARP . thông điệp này là một lời hồi
đáp RARP.
+ HLEN và PLEN : cho phép được sử dụng với mạng bất kỳ vì chúng xác định độ dài của địa chỉ
phần cứng(vật lí) và độ dài địa chỉ logic (ip) của nó.
+ SENDER Hardware address : địa chỉ vật lí của trạm gửi thông điệp ARP (MAC Adress)
+ SENDER IP : địa chỉ logic (ip address) của trạm gửi.
+ TARGET Hardware address : địa chỉ vật lí của trạm nhận thông điệp ARP.
+ TARGET : địa chỉ logic (ip address) của trạm nhận.


5.Tại sao trên hệ thống mạng máy tính IPv4 cần sử dụng kỹ thuật dịch chuyển địa chỉ IP (
NAT – Network Address Translation )? Khái niệm dịch chuyển địa chỉ ip(NAT)? Hãy phân
loại và nêu đặc điểm của từng kỹ thuật NAT đó.
*Vì Trên hệ thống mạng máy tính IPv4 cần sử dụng kỹ thuật dịch chuyển IP (NAT) là do không
gian địa chỉ IPv4 tính đến thời điểm này có thể nói là cạn kiệt. Kỹ thuật NAT cho phép một hay
nhiều địa chỉ IP nội miền (địa chỉ private quy định RFC 1918) được ánh xạ với một hay nhiều địa
chỉ IP ngoại miền, từ đó giúp tiết kiệm được địa chỉ IPv4 và vẫn còn hoạt động được đến bây giờ.
*Khái niệm: - NAT(network address translation) là kỹ thuật cho phép một hay nhiều đỉa chỉ ip nội
miền được ánh xạ với một hay nhiều địa chỉ ip ngoại miền. Nó cho phép sử dụng các dải ip riêng
trong các mạng nội bộ trong khi sử dụng một số ít các địa chỉ Ip Public.
* Phân loại : NAT động, NAT tĩnh và NAT vượt tải
+Dynamic NAT( NAT động): Địa chỉ ip nội bộ sẽ được tự động khớp với một địa chỉ ip
ngoài. Qúa trình ánh xạ vẫn là giữa 1 địa chỉ nội bộ với địa chỉ ngoài nhưng được diễn ra tự động.
Ví dụ: Máy tính có địa chỉ IP 192.168.32.10 luôn được Router biên dịch đến địa chỉ đầu tiên
213.18.123.100 trong dãy địa chỉ IP từ 213.18.123.100 đến 213.18.123.150

N

+ - Static NAT (NAT tĩnh): 1 Địa chỉ ip nội bộ sẽ được ánh xạ thủ công với một địa chỉ ip
public ngoài mạng. Lúc này Nat sẽ coi địa chỉ private là địa chỉ cục bộ bên trong và đja chỉ được
ánh xạ public là địa chỉ chung bên trong.

.H

.P

Ví dụ: Tong Static NAT (NAT tĩnh), địa chỉ IP của máy tính là 192.168.32.10 luôn được
Router biên dịch đến địa chỉ IP 213.18.123.110.

N

A

O

+ NAT overloaded: ánh xạ như một NAT động và NAT tĩnh không được sử dụng. Thay vì
một địa chỉ ngoài chỉ được gán cho 1 địa chỉ Ip nội bộ thì giờ đây nó có thể được gán cho tất cả các
máy nội bộ được phân biệt với nhau dựa trên số công (Port number). Chỉ khi số lượng cổng khả
dụng sử dụng bởi địa chỉ ip ngoài cạn kiệt thì một địa chỉ Ip ngoài thứ 2 mơi được dùng đến với
phương pháp tương tự.
6.Hãy phân tích chức năng của tầng truy cập mạng(Network access layer) trong mô hình
TCP/ip. Liệt kê các giao thức, các kỹ thuật kết nối mạng sử dụng trong tầng này.
*Chức năng:- Giao thức ở tầng này cung cấp cho hệ thống phương thức để truyền dữ liệu trên các
tầng vật lý khác nhau của mạng. Nó định nghĩa cách thức truyền các khối dữ liệu (datagram) IP
- Các chức năng của lớp truy nhập mạng bao gồm ánh xạ địa chỉ IP sang địa chỉ vật lý và đóng gói
(encapsulation) các gói IP thành các frame. Căn cứ vào dạng phần cứng và giao tiếp mạng, lớp truy
nhập mạng sẽ xác lập kết nối với đường truyền vật lý của mạng.
-là lớp thấp nhất trong cấu trúc phân bậc của TCP/IP. Những giao thức ở lớp này cung cấp cho hệ
thống phương thức để truyền dữ liệu trên các tầng vật lý khác nhau của mạng. Lớp này của TCP/IP
tương đương với hai lớp Datalink, và Physical.
-cung cấp các phương tiện kết nối vật lý cáp, bộ chuyển đổi, Card mạng, giao thức kết nối, giao thức
truy nhập đường truyền CSMA/CD, Tolen Ring, Token Bus... Cung cấp các dịch vụ cho tầng
Internet
- Một số giao thức tiêu biểu thuộc tầng này gồm :
+ ATM (Asynchronous Transfer Mode)
+ Ethernet + Token Ring + FDDI (Fiber Distributed Data Interface) + Frame Relay


7.Trình bày cấu trúc gói tin của giao thức TCP.Chức năng của điều khiển liên kết và điều
khiển luồng của giao thức TCP là gì? Chức năng này được thể hiên ở phần nào của header
* Cấu trúc gói tin của giao thức TCP

Một gói tin TCP bao gồm 2 phần: Phần header và dữ liệu - Phần header có 11 trường trong đó 10
trường bắt buộc. Trường thứ 11 là tùy chọn có tên là: options

N

.P

- Source port Số hiệu của cổng tại máy tính gửi. - Destination port Số hiệu của cổng tại máy tính
nhận.

.H

- Sequence number Trường này có 2 nhiệm vụ. Nếu cờ SYN bật thì nó là số thứ

O

tự gói ban đầu và byte đầu tiên được gửi có số thứ tự này cộng thêm 1. Nếu

A

không có cờ SYN thì đây là số thứ tự của byte đầu tiên.

thứ tự gói tin tiếp theo mà bên nhận cần.

N

- Acknowledgement number Nếu cờ ACK bật thì giá trị của trường chính là số

- Data offset Trường có độ dài 4 bít qui định độ dài của phần header (tính theo
đơn vị từ 32 bít). Phần header có độ dài tối thiểu là 5 từ (160 bit) và tối đa là 15
từ (480 bít).
- Reserved Dành cho tương lai và có giá trị là 0.
- Flags (hay Control bits):Bao gồm 6 cờ:• URG Cờ cho trường Urgent pointer • ACK Cờ cho trường
Acknowledgement *PSH Hàm Push • RST Thiết lập lại đường truyền • SYN Đồng bộ lại số thứ tự •
FIN Không gửi thêm số liệu
- Window: Số byte có thể nhận bắt đầu từ giá trị của trường báo nhận (ACK)
- Checksum16 bít kiểm tra cho cả phần header và dữ liệu
*Điều khiển liên kết thiết lập kết nối giữa bên gửi và bên nhận để tránh bị mất dữ liệu nằm ở trường
Sequence number và Acknowledgement number.
*Điều khiển luồng giới hạn tốc độ bên gửi truyền dữ liệu để đảm bảo truyền đáng tin cậy.Bên nhận
liên tục báo bên guiử có thể được nhận bao nhiêu dữ liệu. nằm ở trường Sequence number và
Acknowledgement number, window size.


8.Định dạng gói TCP segment Khi gặp nghẽn mạng, TCP sẽ dùng các kỹ thuật nào để xử lý?
Mô tả ngắn gọn về các kỹ thuật đó.
* TCP segment

Bit 0

15 16

31

Source port

Data
Offset

Reserved
Checksum
Options

Destination port

U
G
R

Sequence number
Acknowled gment number
A
P
R
S
F
C
S
S
I
I
Windown
K
H
T
N
N
Urgent pointer
Padding
TCP data

N

A

O

.H

.P

N

Các vùng SOURCE PORT và DESTINATION PORT chứa các giá trị cổng TCP để xác định các
chương trình ứng dụng tại hai đầu của kết nối. -Sequence Number: 32 bits, số thứ tự của gói số liệu
khi phát. -AcknowLegment Number: bên thu xác nhận thu được dữ liệu đúng. -Offset (4 bit): Độ
dài Header gói tin TCP. -Reversed (6 bit): Lấp đầy bằng 0 để dành cho tương lai. -Flag: Các bits
điều khiển.URG: Vùng con khẩn cấp.ACK: Vùng báo nhận (ACK number) PSH: Chức năng
PUSH..RST: Khởi động lại (reset liên kết). SYN: Đồng bộ các số liệu tuần tự (sequence
number).FIN: Không còn dữ liệu từ trạm nguồn. -Window(16 bit): Số lượng các Byte dữ liệu trong
vùng cuar số bên phát -Checksum (16 bít): Mã kiểm soát lỗi (theo phương pháp CRC) -Urgent
Pointer (16 Bit): Số thứ tự của Byte dữ liệu khẩn, khi URG được thiết lập.-Option (độ dài thay
đổi): Khai báo độ dài tối đa của TCP data trong một Segment.-Padding (độ dài thay đổi): Phần chèn
thêm vào Header.
* Cách thức giao thức TCP xử lý khi gặp nghẽn mạng? a) Kỹ thuật giảm thật nhanh Tránh nghẽn
mạch bằng cách giảm theo cấp số nhân: khi bị mất một segment, giảm kích thước cửa sổ nghẽn
mạch đi một nửa (cho tới khi chỉ còn kích thước của một segment). Với những segment vẫn
còn nằm trong cửa sổ được phép, nhượng bộ bằng cách gia tăng bộ đếm thời gian truyền lại
theo hàm mũ.
b) Kỹ thuật khởi đầu chậm Phục hồi theo cách khởi động chậm (thêm vào từ từ): bất cứ khi nào
khởi động giao dịch (truyền dữ liệu) trên một kết nối mới hay gia tăng lượng giao dịch sau một
giai đoạn bị nghẽn mạch, hay bắt đầu với kích thước cửa sổ nghẽn mạch bằng một segment và
gia tăng kích thước cửa sổ nghẽn mạch thêm một segment mỗi lần nhận được một lời đáp.
c) Kĩ thuật cắt bớt phần dưới khi nghẽn mạng - Tên của nó ,”cắt bớt phần đuôi”, phản ánh ảnh
hưởng chính sách này đối với các datagram gửi tiếp theo sau.Một khi hang đợi bị đầy ,bộ định
tuyến sẽ hủy bỏ tất cả những datagram sau đó. Nghĩa là , bộ định tuyến hủy bỏ “phần đuôi” của
chuỗi dữ liệu.
d) Kĩ thuật hủy bỏ sớm ngẫu nhiên (RED) Chính sách của RED trong các bộ định tuyến: nếu
hàng đợi của dữ liệu đến bị đầy khi có một datagram gửi đến thì sẽ hủy bỏ datagram; nếu hang
đợi của dữ liệu đến chưa đầy nhưng đã vượt qua kích thước giới hạn trên, để tránh làm ảnh
hưởng đến toàn bộ Internet thì phải hủy bỏ datagram một cách ngẫu nhiên theo một hàm xác
suất P.


9.Nguyên lý cửa sổ trượt của giao thức TCP. Các khái niệm Segment, stream, và số thứ tự của
giao thức TCP
*Kỹ thuật cửa sổ trượt
Kỹ thuật cửa sổ trượt là một dạng phức tạp hơn của đáp lời tích cực và truyền lại so với phương
pháp đơn giản được trình bày. Các giao thức cửa sổ trượt sử dụng băng thông của mạng tốt hơn bởi
vì chúng cho phép nơi gửi truyền nhiều gói dữ liệu trước khi qua trạng thái đợi acknowledgement.
Cách dễ dàng nhất để tưởng tượng hoạt động của cửa sổ trượt là xét một dãy các gói dữ liệu sắp
được truyền. Giao thức này đặt một cửa sổ nhỏ có kích thước cố định lên dãy này và truyền đi tất cả
những gói dữ liệu nào nằm trong cửa sổ. Một khi nơi gửi nhận một acknowledgement của gói dữ
liệu đầu tiên bên trong cửa sổ, nó "trượt" cửa sổ qua bên phải và gửi gói dữ liệu kế tiếp. Cửa sổ tiếp
tục trượt khi nơi gửi vẫn còn nhận được acknowledgement. Hiệu suất của giao thức cửa sổ trượt tuỳ
thuộc vào kích thước cửa sổ và tốc độ nhận dữ liệu của mạng.
Cửa sổ phân chia dãy các gói dữ liệu thành ba tập hợp:
Bên trái của cửa sổ là những gói dữ liệu đã được truyền đi thành công, đầu kia đã nhận
được, đầu này đã nhận được lời đáp;

-

Bên phải của cửa sổ là những gói dữ liệu chưa được truyền đi;

-

Bên trong cửa sổ là những gói dữ liệu đang được truyền đi. Gói dữ liệu được đánh số thấp
nhất trong cửa sổ là gói dữ liệu đầu tiên trong dãy này mà chưa nhận được lời đáp.

*Segment, stream, và số thứ tự

TCP xem một dòng dữ liệu như một dãy các byte hay byte mà nó chia thành những đoạn
(segment) để truyền đi. Thông thường, mỗi segment di chuyển qua internet trong một IP
datagram.
TCP sử dụng một cơ chế cửa sổ trượt đặc biệt để giải quyết hai vấn đề quan trọng: hiệu quả
việc truyền và điều khiển tốc độ dòng dữ liệu. Giống như giao thức cửa sổ trượt đã mô tả
trước đây, cơ chế cửa sổ trượt cho TCP cho phép nó gửi đi nhiều segment trước khi nhận
được một lời đáp (acknowledgement).
Cơ chế cửa sổ trượt TCP hoạt động theo byte, không phải theo segment hay theo gói dữ
liệu. Các byte của dòng dữ liệu được đánh số tuần tự, và nơi gửi duy trì ba con trỏ phối hợp
với mỗi kết nối. Các con trỏ này định nghĩa cửa sổ trượt như minh hoạ trong hình. Con trỏ
đầu tiên đánh dấu biên bên trái cửa sổ trượt, tách biệt những byte đã được gửi và đã nhận
được lời đáp ra khỏi những byte còn chưa được đáp lời. Con trỏ thứ hai đánh dấu biên bên
phải cửa sổ trượt và xác định byte cao nhất trong dãy này mà có thể được gửi đi trước khi
nhận được thêm lời đáp. Con trỏ thứ ba đánh dấu biến bên trong cửa sổ để tách biệt những
byte đã được gửi đi và những byte chưa được gửi đi. Phần mềm giao thức gửi đi tất cả các
byte trong cửa sổ mà không hề trì hoãn, vì vậy đường biên bên trong cửa sổ trượt luôn luôn
di chuyển nhanh chóng từ trái sang phải.

N

A

-

O

.H

.P

N

-

-

-


10. Trình bày chức năng của giao thức UDP, định dạng gói tin(thông điệp) UDP?
Trình bày chức năng của UDP cấu trúc gói tin UDP. So sánh UDP và TCP.
*Chức năng: UDP cung cấp dịch vụ chuyển phát datagram không định hướng, không có độ tin cậy,
sử dụng IP để chuyển thông điệp giữa các máy. Nó sử dụng IP để chuyển tải thông điệp, nhưng
thêm vào khả năng phân biệt nhiều đích đến bên trong một máy tính. UDP được sử dụng khi tốc độ
được ưu tiên và sửa lỗi không cần thiết.
*Định dạng thông điệp: Mỗi thông điệp UDP được gọi là user datagram.Về mặt khái niệm, một user
datagram bao gồm hai phần:+ Một phần đầu UDP: Chia thành bốn vùng 16 bit để xác định cổng mà
thông điệp được gửi đi từ đó, cổng mà thông điệp được dự kiến gửi đến, độ dài thông điệp, và UDP
checksum + Một vùng dữ liệu.
Source port
Length

Destination port
Checksum

*Cấu trúc gói tin UDP.

N

A

O

.H

.P

N

Data
Cấu trúc thông điệp UDP
+ Vùng source port và destination port(16 bit) được dùng để demultiplex các datagram trong các
tiến trình đang đợi để nhận chúng.Source port là vùng tuỳ chọn. Khi được dùng, nó xác định cổng
mà lời đáp sẽ được gửi đến; nếu không được dùng, nó sẽ có giá trị zero. +Vùng length chứa độ dài
của UDP datagram tính theo Byte, bao gồm cả phần đầu UDP và dữ liệu của người sử dụng. Như
thế giá trị tối thiểu của length là 8, chính là độ dài của phần đầu UDP. + UDP checksum (vùng tùy
chọn chẳng cần dung đến) để bảo đảm rằng dữ liệu nhận được nguyên vẹn và nên được sử dụng.

Phần header của UDP chỉ chứa 4 trường dữ
liệu, trong đó có 2 trường là tùy chọn (Source Port và Checksum). Source port: Trường này xác
định cổng của người gửi thông tin và có ý nghĩa nếu muốn nhận thông tin phản hồi từ người nhận.
Nếu không dùng đến thì đặt nó bằng 0.Destination port: Trường xác định cổng nhận thông tin, và
trường này là cần thiết.Length: Trường có độ dài 16 bit xác định chiều dài của toàn bộ datagram:
phần header và dữ liệu. Chiều dài tối thiểu là 8 byte khi gói tin không có dữ liệu, chỉ có header.
Checksum: Trường checksum 16 bit dùng cho việc kiểm tra lỗi của phần header và dữ liệu
*So sánh TCP UDP: - Giống nhau : Đều là các giao thức mạng TCP/IP, đều có chức năng kết nối
các máy lại với nhau, và có thể gửi dữ liệu cho nhau....
- Khác nhau : Các header của TCP và UDP khác nhau ở kích thước (20 và 8 byte) nguyên nhân chủ
yếu là do TCP phải hộ trợ nhiều chức năng hữu ích hơn(như khả năng khôi phục lỗi). UDP dùng ít
byte hơn cho phần header và yêu cầu xử lý từ host ít hơn.
a) TCP :+ Hoạt động theo hướng kết nối (connection-oriented)+ Dùng cho mạng WAN+ Không cho
phép mất gói tin+ Đảm bảo việc truyền dữ liệu+ Tốc độ truyền thấp hơn UDP
b) UDP:+ Hoạt động theo hướng phi kết nối (connectionless)+ Dùng cho mạng LAN+ Cho phép
mất dữ liệu+ Không đảm bảo.+ Tốc độ truyền cao, VolP truyền tốt qua UDP


12.Cấu trúc Data frame của mạng Ethernet và Token Ring
* Cấu trúc DataFrame của mạng Ethernet:

N

A

O

.H

.P

N

- Khuôn dữ liệu của Ethernet frameCác thành phần của frame Ethernet 802.3 bao gồm:
-- Preamble (Phần mở đầu)– Đánh dấu bắt đầu của toàn bộ frame, là tín hiệu thông báo tới mạng
rằng dữ liệu đang truyền. (Vì trường này là một phần của quá trình giao tiếp, nên nó không được
tính vào kích thước của frame)-- Start of Frame Delimiter (SFD) – Chứa thông tin khởi đầu của
việc định địa chỉ frame.-- Destination Address – Chứa địa chỉ của nút đích.-- Source Address –
Chứa địa chỉ của nút nguồn.-- Length (LEN) – Chứa chiều dài của gói.-- Data – Chứa dữ liệu
được truyền từ nút nguồn.-- Pad – Được sử dụng để tăng kích thước của frame tới kích thước
yêu cầu nhỏ nhất là 46 byte.-- Frame Check Sequence (FCS) – Cung cấp một giải thuật để xác
định xem dữ liệu nhận được có chính xác hay không. Giải thuật được sử dụng thông thường nhất
là Cyclic Redundancy Check (CRC).
* Cấu trúc DataFrame của mạng Token Ring

Các thành phần gồm:
-- Start Delimiter (SD) – Báo hiệu bắt đầu gói. Nó là một trong ba trường tạo thành khuôn dạng
Token Ring.-- Access Control (AC) – Chứa thông tin về độ ưu tiên của frame. Nó là trường thứ
hai tạo thành khuôn dạng Token Ring.-- Frame Control (FC) – Định nghĩa kiểu của frame, được
dùng trong Frame Check Sequence.-- Destination Address – Chứa địa chỉ của nút đích.
-- Source Address – Chứa địa chỉ của nút nguồn.-- Data – Chứa dữ liệu được truyền từ nút
nguồn, cũng có thể chứa thông tin quản lý và tìm đường.-- Frame Check Sequence (FCS) –
Được sử dụng để kiểm tra tính toàn vẹn của frame.-- End Delimiter (ED) – Báo hiệu kết thúc
frame. Nó là trường thứ ba của khuôn dạng Token Ring.-- Frame Status (FS) – Báo hiệu nút
đích nhận dạng và sao chép đúng frame hay không.


13. Khái niệm MTU của mạng? Khái niệm phân mảnh, hợp nhất gói tin IP?
* Khái niệm:- Maxium Transmission Unit (MTU) là kích thước gói dữ liệu lớn nhất, được đo bằng
byte, có thể truyền tải qua một mạng lưới. Gói có thể có kích thước cố định hoặc thay đổi, tùy thuộc
vào hình thức mạng và giao thức ( hay là một định dạng thống nhất).
*Phân mảnh(fragmentation) là quá trình xảy ra khi kích thước của các datagram lớn hơn MTU tối
thiểu của mạng vật lý trung gian trong Internet. Lúc này các datagram sẽ được chia thành những
phần nhỏ hơn hoặc bằng kích thước MTU được gọi là fragment để có thể truyền qua mạng vật lý.
*Quá trình hợp nhất gói tin: Khi IP nhận được một gói phân mảnh, nó giữ phân mảnh đó trong
vùng đệm, cho đến khi nhận được hết các gói IP trong chuỗi phân mảnh có cùng trường định danh.
Khi phân mảnh đầu tiên được nhận, IP khởi động một bộ đếm thời gian (giá trị ngầm định là 15s).
IP phải nhận hết các phân mảnh kế tiếp trước khi đồng hồ tắt. Nếu không IP phải huỷ tất cả các
phân mảnh trong hàng đợi hiện thời có cùng trường định danh. Khi IP nhận được hết các phân
mảnh, nó thực hiện hợp nhất các gói phân mảnh thành các gói IP gốc và sau đó xử lý nó như một
gói IP bình thường. IP thường chỉ thực hiện hợp nhất các gói tại hệ thống đích của gói.
14. Khái niệm định tuyến, phân loại theo các cơ sở khác nhau? Các thuật toán định tuyến IP?
Ví dụ về cách thực hiện của từng thuật toán?

.P

N

* Khái niệm:- Định tuyến là quá trình xác định đường đi tốt nhất trên một mạng máy tính để gói tin
tới được đích theo một số thủ tục nhất định nào đó thông qua các nút trung gian là các bộ định tuyến
router. Thông tin về những con đường này có thể được cập nhật tự động từ các router khác hoặc là
do người quản trị mạng chỉ định cho router.

N

A

O

.H

* Phân loại:Định tuyến trực tiếp:- Để truyền một IP datagram, nơi gửi sẽ đóng gói datagram trong
frame vật lý, ánh xạ địa chỉ IP đích vào địa chỉ vật lý, và sử dụng phần cứng mạng để truyền nó đi.
Việc truyền một IP datagram giữa hai máy trên cùng một mạng vật lý sẽ không có sự tham dự của
bộ định tuyến. Máy gửi sẽ đóng gói datagram trong frame vật lý, kết hợp địa chỉ IP với địa chỉ phần
cứng, và gửi frame kết quả trực tiếp đến máy đích.Để xem máy đích có nối trực tiếp vào cùng mạng
không, máy gửi sẽ trích ra phần mạng của địa chỉ IP đích và so sánh nó với phần mạng của địa chỉ
IP của nó. Nếu chúng giống nhau, nghĩa là có thể gửi datagram đi trực tiếp.
Định tuyến gián tiếp:Phát chuyển gián tiếp sẽ khó khăn hơn phát chuyển trực tiếp bởi vì máy gửi
phải xác định tuyến này phải truyền datagram này đi đến mạng cuối cùng của nó.Để hình dung xem
việc định tuyến gián tiếp làm việc như thế nào, hãy tưởng tượng một Internet lớn có nhiều mạng nối
với nhau thông qua các bộ định tuyến nhưng chỉ có hai máy ở hai đầu. Khi một máy muốn gửi cho
máy khác, nó đóng gói datagram và gửi đến bộ định tuyến gần nhất.Các bộ định tuyến trong một
TCP/IP Internet hình thành nên một cấu trúc cùng hợp tác và liên kết (Internet). Các datagram đi từ
bộ định tuyến này đến bộ định tuyến mà có thể phát chuyển datagram một các trực tiếp.
* Ví dụ thực hiện 2 thuật toán- Distance vector: Hoạt động theo nguyên tắc Neighbor , nghĩa là mỗi
router sẻ gửi routing-table của mình cho tất cả các router được nối trực tiếp với nó . Các router đó
sau đó so sánh với bảng routing-table mà mình hiện có và kiểm tra lại các tuyến đường của mình
với các tuyến đường mới nhận được, tuyến đường nào tối ưu hơn sẻ được đưa vào routing-table .
Các gói tin update sẽ được gửi theo định kỳ (30 giây với RIP ,90 giây đối với IGRP) .
- Link State: Các giao thức định tuyến thuộc loại này như OSPF, IS-IS .Link State không gửi bảng
định tuyến của mình , mà chỉ gửi tình trạng của các đường link trong linkstate-database của mình đi
cho các router khác, các router sẽ áp dụng giải thuật SPF (shortest path first ) , để tự xây dựng
routing-table riêng cho mình . Khi mạng đã hội tụ , Link State protocol sẽ không gửi update định kỳ
mà chỉ gởi khi nào có một sự thay đổi trong mạng (1 line bị down , cần sử dụng đường back-up)


15. Định dạnh thông điệp OSPF Định dạng thông điệp RIP

.P

N

*Định dạng thông điệp OSPF
Mỗi thông điệp OSPF bắt đầu bởi một phần đầu cố định 24 byte, như trong hình:
0
7
15
31
Vertion
Type
Packet length
Router ID
Area ID
Checksum
AuType
Authentication
Authentication
Định dạng thông điệp OSPFVùng VERSION xác định phiên bản của giao thức.
Vùng TYPE xác định kiểu của thông điệp, theo bảng sau:1: Hello 2: Database description
3: Link status request 4: Link status update 5: Link status acknowledgment
Vùng có tên SOURCE ROUTER IP ADDRESS cho ta địa chỉ của nơi gửi,Vùng có tên
AREA ID là con số định danh 32 bit của khu vực này.Bởi vì mỗi thông điệp có thể bao gồm
việc xác minh, nên vùng AUTHENTICATION TYPE xác định mô hình xác minh nào được
sử dụng hiện tại, có nghĩa là không xác minh và có nghĩa là sử dụng một password đơn
giản).

N

A

O

.H

Định dạng thông điệp RIP:Định dạng thong điệp RIPv1 Một thông báo RIP gồm Header và lên
đến 25 mục tuyến đường.
Command
Version
Must be zero
AFI
Must be zero
IP address
Must be zero
Must be zero
Metric
RIPv1:Command =1 là một RIP request: yêu cầu hệ thống khác gửi toàn bộ hoặc 1 phần bảng định
tuyến của nó.2 là RIP reply: bao gồm toàn bộ hoặc phần bảng định tuyến của nơi gửi.Version:
Chứa số phiên bản giao thức.Các phiên bản của RIP, 0x01 cho RIPv1.AFI: Địa chỉ Family
Identifier, luôn là 2 đối với các địa chỉ IP.IP address: Điểm đến địa chỉ IP của các tuyến đường; có
thể là một mạng tự nhiên, subnet hoặc một địa chỉ host.Metric: Chi phí của các tuyến đường.
Định dạng tin nhắn RIPv2:Các định dạng của thông điệp RIPv2 cũng tương tự như với RIPv1:
Command
Version
Unused
AFI
Route tag
IP address
Subnet mask
Next hop
Metric
RIPv2:Có khuôn dạng giống Rip nhưng nó bỏ qua trường “set to 0”
• Version: Phiên bản của RIP. Đối với RIPv2 giá trị là 0x02.
• Route Tag: hỗ trợ EGP,nó nhớ một số hiệu hệ thống độc lập AS của EGP và BGP.
• IP address: Điểm đến địa chỉ IP. Nó có thể là một địa chỉ mạng tự nhiên, địa chỉ subnet
hoặc địa chỉ host.*Subnet Mask: của mỗi tuyến áp dụng cho địa chỉ IP tương ứng
• Next Hop:là địa chỉ các gói dữ liệu tới địa chỉ IP đích tương ứng cần được gửi tới.


16.Khái niệm các giao thức routing Distance Vector
Thuật giải vector khoảng cách (còn được gọi là khoảng cách vector, Ford Fulkeson, bellman
Ford,…với các tên sau cùng chính là tên của những nhà nhiên cứu đã tìm ra thuật giải) để chỉ một
các thuật giải mà bộ định tuyến sử dụng để nhân bản thông tin định tuyến. ý tưởng trong thuật giải
vector khoảng cách rất là đơn giản. Bộ định tuyến duy trì một danh sách của tất cả các tuyến đường
đã biết trong một bảng.Khi bắt đầu hoạt động, bộ định tuyến khởi động bẳng định tuyến của nó
trong đó mỗi dòng dành cho một mạng được kết nối trực tiếp. Mỗi dòng trong bảng xác định một
mạng đích và thông tin về khoảng cách đến mạng đó, thường được theo số trạm (sẽ được định nghĩa
một cách chính xác sau này).Một cách đình kỳ, mỗi bộ định tuyến gửi đi một bản sao của bảng định
tuyến của nó đến bộ định tuyến bất kỳ nào khác mà nó có thể đến được trực tiếp.Thuật ngữ vector
khoảng cách có được từ thông tin được gửi trong các thông điệp theo định kỳ. Một thông điệp chứa
danh sách các cặp (V, D) với:V xác định một đích (được gọi là vector) và D là khoảng cách đi đến
đích đó.Trong cách thiết kế đó, tất cả các bộ định tuyến phải tham gia trong việc trao đổi vector
khoảng cách để có được các tuyến đường được nhất quán và hiệu quả.
17. Cấu trúc ip datagram

N

A

O

.H

.P

N

VERS HLEN
Service TYPE
Toltal Length
Identification
Flags
Fragment offset
Time to live
Protocol
Header checksum
Source ip address
Destination ip address
Ip options
Padding
Ip datagram data
Ý nghĩa các thông số.
+ VERS (4bits) chỉ version hiện hành của giao thức hiện được cài đặt
+ HLEN (4 bit): chỉ độ dài phần đầu (Internet header length) của gói tin datagram, tính theo đơn vị
từ (32bit).
+Service oftype (8bit): đặc tả tham số về dịch vụ nhằm thông báo cho mạng biết dịch vụ nào mà gói
tin muốn được sử dụng chẳng hạn ưu tiên, thời gian trậm trễ, năng suất truyền và độ tin cậy.
+ Total length (16bits): chỉ độ dài toàn bộ gói tin, kể cả phần đầu với chiều dài tối đa là 65535
bytes.
+ Identification (16 bits): Dùng để định dạng duy nhất cho 1 datagram trong khoảng thời gian nó
vẫn còn trên liên mạng. + Flags (3 bits): Các gói tin trên đường đi có thể bị phân đoạn thì trường
Flags dùng điều khiển phân đoạn và tái lắp ghép gói dữ liệu.
+ Fragment Offset (13 bits): Trường này chỉ vị trí fragment trong datagram tính theo đơn vị 8
bytes.Có nghĩa là phần dữ liệu mỗi gói tin (trừ gói tin cuối cùng) phải chứa một vùng dữ liệu có độ
dài là bội số của 8 bytes + Time to Live (8 bits): qui định thời gian tồn tại (tính bằng giây) của gói
tin trong mạng để tránh tình trạng một gói tin bị loop trên mạng.
+ Protocol (8 bits): chỉ giao thức tầng kế tiếp sẽ nhận vùng dữ liệu ở trạm đích (hiện tại thường là
TCP hoặc UDP được cài đặt trên IP).
+ Header checksum (16 bits): Trường này chỉ dùng để kiểm soát lỗi cho tiêu đề IP datagram
+ Source Address (32 bits): địa chỉ của trạm nguồn.
+ Destination Address (32 bits): địa chỉ của trạm đích.
+ Option (có độ dài thay đổi): Sử dụng trong một số chức năng định tuyến đặc biệt.
+ Padding (độ dài thay đổi): vùng đệm, được dùng để đảm bảo cho phần header luôn kết thúc ở
một mốc 32 bits
+ Data (độ dài thay đổi): Mang dữ liệu của lớp trên,có độ dài tối đa là 65535 bytes.


18.Các cải tiến trong IPv6? Các kỹ thuật chuyển đổi giữa IPv4 và IPv6.
- Cải tiến: + Địa chỉ dài 128 bit. + Ipsec được yêu cầu.
+ Đạng dạng được luồng dữ liệu nên hỗ trợ QoS tốt hơn.
+ Sự phân mảnh chỉ xảy ra tại host gửi.
+ Không có checksum header.
+ Tất cả dữ liệu tùy chọn được chuyển vào phần header mở rộng.
+ ICMPv4 Router Discovery được thay thế bởi message ICMPv6 Router Discovery và
Router Advertisement .
+ Ipv6 Không có địa chỉ broadcast mà địa chỉ multicast đến tất cả các node.
+ Sử dụng các mẫu tin AAAA trong Dns để ánh xạ tên host thành địa chỉ Ipv6.
** Chuyển đổi ipv4 và ipv6:

N

+ Sử dụng kỹ thuật đường hầm: là một phương pháp sử dụng cơ sở hạ tầng sẵn có của mạng Ivp4 đê
thực hiện các kết nối Ipv6. Kỹ thuật này sẽ bọc gói tin IPV6 trong gói tin IPV4, nhân lại gói tin Ipv6
ban đầu tại điểm đích cuối đường hầm Ipv4.

.H

19.Khái niệm subneting

.P

+ Dual Stack: Cho phép Ipv4 và Ipv6 cùng hoạt động trong một thiết bị mạng.

N

A

O

-- Là tổ hợp những kĩ thuật phân chia không gian địa chỉ thuộc mỗi lớp mạng cho trước
thành những lớp mạng nhỏ hơn bằng cách lấy một số bít ở phần host address để làm địa chỉ
mạng cho mang con (subnet)
-- Một số khái niệm liên quan tới việc phân chia đia chỉ các mạng con
-- Default mask( giá trị trần địa chỉ mạng )được định nghĩa cho từng lớp từng lớp địa chỉ
A,B,C.thực chất là giá trị thập phân cao nhất (khi tất cả các bit đều băg 1) trong các byte dành
cho địa chỉ mạng net ID
Default mask
Lớp A:255.0.0.0
lớp B 255.255.0.0
lớp C : 255.255.255.0
Subnetmask (giá trị trần của từng mạng con )
-- Subnetmask là kết hợp của default mask với giá trị thập phân cao nhất của các bít
lấy từ các byte của địa chỉ host sang phần địa chỉ mạng để tao đc mạng con
-- Subnetmask bao giờ cũng đi kèm với địa chỉ mạng tiêu chuẩn để cho người đọc biết
địa chỉ mạng tiêu chuẩn này dùng cả cho 254 host hay chia ra thành các mạg con mặt khác nó
còn giúp router trong viêc đình tuyến cuộc gọi
-- nguyên tắc chung : lấy bớt một số bít phần địa chỉ host để tao đươc mạng con lấy đi
bao nhieu bít phụ thuộc và số mag con là cần thiết (subnetmask ) mà nhà khai thác mạng quyết
định sẽ tạo ra


21.Tham chiếu mô hình TCP/IP và mô hình OSI, chức năng các tầng của mô hình TCP/IP, mô
hình OSI. Mô hình tcp/ip
Application

Stream

Transport

Segment/datagram

Internet

Datagram

Network Access
Frame
1. Tầng truy cập mạng (Network Access) - Giao thức ở tầng này cung cấp cho hệ thống phương
thức để truyền dữ liệu trên các tầng vật lý khác nhau của mạng. Nó định nghĩa cách thức truyền các
khối dữ liệu (datagram) IP - Các chức năng của lớp truy nhập mạng bao gồm ánh xạ địa chỉ IP sang
địa chỉ vật lý và đóng gói (encapsulation) các gói IP thành các frame. Căn cứ vào dạng phần cứng
và giao tiếp mạng, lớp truy nhập mạng sẽ xác lập kết nối với đường truyền vật lý của mạng.- Một số
giao thức tiêu biểu thuộc tầng này gồm :+ ATM (Asynchronous Transfer Mode) + Ethernet + Token
Ring + FDDI (Fiber Distributed Data Interface) + Frame Relay

.H

.P

N

2. Tầng liên mạng (Internet) - Mục đích của lớp Internet là chọn lấy một đường dẫn tốt nhất xuyên
qua mạng cho các gói di chuyển tới đích. Giao thức chính hoạt động tại lớp này là Internet Protocol
(IP). Sự xác định đường dẫn tốt nhất và chuyển mạch gói diễn ra tại lớp này. - Chức năng của
Internet Protocol như sau: + Định nghĩa cấu trúc các gói dữ liệu là đơn vị cơ sở cho việc truyền dữ
liệu trên Internet + Định nghĩa phương thức đánh địa chỉ IP + Truyền dữ liệu giữa tầng vận chuyển
và tầng mạng + Định tuyến để chuyển các gói dữ liệu trong mạng + Thực hiện phân mảnh và hợp
nhất các gói dữ liệu và tách chúng trong các gói dữ liệu ở tầng liên kết

N

A

O

- Ngoài ra còn các giao thức:+ ICMP (Internet Control Message Protocol) Có chức năng thông báo
lỗi trong trường hợp truyền dữ liệu bị hỏng.+ ARP (Address Resolution Protocol) xác định địa chỉ
lớp liên kết số liệu (MAC address) khi đã biết trước địa chỉ IP.+ RARP (Reverse Address
Resolution Protocol) xác định các địa chỉ IP khi biết trước địa chỉ MAC.
3. Tầng vận chuyển (Transport) - Có trách nhiệm thiết lập phiên truyền thông giữa các máy tính và
quy định cách truyền dữ liệu. 2 giao thức chính trong tầng này gồm:+ UDP (User Datagram
Protocol): Còn gọi là Giao Thức Gói Người Dùng. UDP cung cấp các kênh truyền thông phi kết nối
nên nó không đảm bảo truyền dữ liệu 1 cách tin cậy. Các ứng dụng dùng UDP thường chỉ truyền
những gói có kích thước nhỏ, độ tin cậy dữ liệu phụ thuộc vào từng ứng dụng + TCP (Transmission
Control Protocol): Ngược lại với UDP, TCP cung cấp các kênh truyền thông hướng kết nối và đảm
bảo truyền dữ liệu 1 cách tin cậy. TCP thường truyền các gói tin có kích thước lớn và yêu cầu phía
nhận xác nhận về các gói tin đã nhận.
4. Tầng ứng dụng (Application):Gồm nhiều giao thức cung cấp cho các ứng dụng người dùng. Được
sử dụng để định dạng và trao đổi thông tin người dùng. Một số giao thức thông dụng trong tầng này
là:
+ DHCP (Dynamic Host Configuration Protocol): Giao Thức Cấu Hình Trạm Động
+ DNS (Domain Name System): Hệ Thống Tên Miền
+ SNMP (Simple Network Management Protocol): Giao Thức Quản Lý Mạng Đơn Giản
+ FTP (File Transfer Protocol): Giao Thức Truyền Tập Tin
+ TFTP (Trivial File Transfer Protocol): Giao Thức Truyền Tập Tin Bình Thường
+ SMTP (Simple Mail Transfer Protocol): Giao Thức Truyền Thư Đơn Giản
+ Telnet: Dịch vụ truy cập từ xa


Mô hình OSI 7 tầng

Tầng 1: Vật lý (Physical)
Tầng vật lý (Physical layer) tầng vật lý cung cấp các đặc trưng điện của các tín hiệu được dùng để
khi chuyển dữ liệu trên cáp từ một máy này đến một máy khác của mạng, kỹ thuật nối mạch điện,
tốc độ cáp truyền dẫn.

N

Tầng 2: Liên kết dữ liệu (Data link)

.P

Tầng 3: Mạng (Network)

A

O

.H

Chức năng chủ yếu của tầng liên kết dữ liệu là thực hiện thiết lập các liên kết, duy trì và huỷ bỏ các
liên kết dữ liệu. Kiểm soát lỗi và kiểm soát lưu lượng. Tầng này bao gồm 2 tầng nhỏ là: Media
Access Control (MAC), Logical Link Control (LLC).

N

Tầng mạng cung các các phương tiện để truyền các gói tin qua mạng, thậm chí qua một mạng của
mạng (network of network). Hai chức năng chủ yếu của tầng mạng là chọn đường (routing) và
chuyển tiếp (relaying).
Tầng 4: Vận chuyển (Transport)
Là tầng chịu trách nhiệm, đảm bảo việc chuyển gói tin tới người dùng (kết nối end to end). Kiểm
soát độ tin cậy của kết nối, theo dõi các gói tin và truyền lại các gói tin lỗi. Cung cấp các địa chỉ
cổng dịch vụ (address port). Giao thức chính được sử dụng ở tầng này là TCP và UDP
Tầng 5: Giao dịch (Session)
Tầng giao dịch (session layer) thiết lập "các giao dịch" giữa các trạm trên mạng, nó đặt tên nhất
quán cho mọi thành phần muốn đối thoại với nhau và lập ánh xa giữa các tên với địa chỉ của chúng.
Tầng 6: Tŕnh bày (Presentation)Trong giao tiếp giữa các ứng dụng thông qua mạng với cùng một
dữ liệu có thể có nhiều cách biểu diễn khác nhau. Tầng tŕnh bày (Presentation layer) phải chịu trách
nhiệm chuyển đổi dữ liệu gửi đi trên mạng từ một loại biểu diễn này sang một loại khác. Để đạt
được điều đó nó cung cấp một dạng biểu diễn chung dùng để truyền thông và cho phép chuyển đổi
từ dạng biểu diễn cục bộ sang biểu diễn chung và ngược lại.
Tầng 7: Ứng dụng (Application)Tầng ứng dụng (Application layer) là tầng cao nhất của mô h́ nh
OSI, nó cung cấp các giao diện giữa người sử dụng và môi trường OSI và giải quyết các kỹ thuật
mà các chương tŕnh ứng dụng dùng để giao tiếp với mạng.


1. Khái niệm địa chỉ MAC (địa chỉ vật lý), cách thiết bị xác định địa chỉ MAC khi biết địa chỉ IP
của thiết bị khác?
2. Hãy trình bày chức năng của giao thức ICMP (Internet Control Message Protocol) . Có
mấy loại thông điệp ICMP? Hãy mô tả mục đích của từng loại thông điệp đó. Mô tả
nguyên lý hoạt động của lệnh PING dựa trên ICMP và cấu trúc các thông điệp mà nó sử
dụng. Định dạng thông báo ICMP báo đích không đến được? Nguyên lý xử lý khi gặp
nghẽn mạng của giao thức ICMP?
3. Trình bày chức năng và Nguyên lý hoạt động của giao thức ARP,cấu trúc thông điệp ARP
request.

N

A

O

.H

.P

N

4. Hãy trình bày quá trình bắt tay 3 bước (Three-way handshaking) thiết lập kết nối của giao
thức TCP. Vẽ hình minh họa.
5. Tại sao trên hệ thống mạng máy tính IPv4 cần sử dụng kỹ thuật dịch chuyển địa chỉ IP (
NAT – Network Address Translation )? Khái niệm dịch chuyển địa chỉ ip(NAT)? Hãy phân
loại và nêu đặc điểm của từng kỹ thuật NAT đó.
6. Hãy phân tích chức năng của tầng truy cập mạng(Network access layer) trong mô hình
TCP/ip. Liệt kê các giao thức, các kỹ thuật kết nối mạng sử dụng trong tầng này.
7. Trình bày cấu trúc gói tin của giao thức TCP.Chức năng của điều khiển liên kết và điều
khiển luồng của giao thức TCP là gì? Chức năng này được thể hiên ở phần nào của header
8. Định dạng gói TCP segment Khi gặp nghẽn mạng, TCP sẽ dùng các kỹ thuật nào để xử lý?
Mô tả ngắn gọn về các kỹ thuật đó.
9. Nguyên lý cửa sổ trượt của giao thức TCP. Các khái niệm Segment, stream, và số thứ tự
của giao thức TCP.
10. Trình bày chức năng của UDP cấu trúc gói tin UDP. So sánh UDP và TCP.
Trình bày chức năng của giao thức UDP, định dạng gói tin(thông điệp) UDP?
11. Định tuyến là gì? Hãy phân loại các phương thức định tuyến? Bảng định tuyến của router
bao gồm những thông tin gì?
12. Cấu trúc Data frame của mạng Ethernet và Token Ring
13. Khái niệm MTU của mạng? Khái niệm phân mảnh, hợp nhất gói tin IP?
14. Khái niệm định tuyến, phân loại theo các cơ sở khác nhau? Các thuật toán định tuyến IP?
Ví dụ về cách thực hiện của từng thuật toán?
15. Định dạnh thông điệp OSPF Định dạng thông điệp RIP
16. Khái niệm các giao thức routing Distance Vector
17. Cấu trúc ip datagram
18. Các cải tiến trong IPv6? Các kỹ thuật chuyển đổi giữa IPv4 và IPv6.
19. Khái niệm subneting
20. Các tính chất của chuyển phát tin cậy.
21. Tham chiếu mô hình TCP/IP và mô hình OSI, chức năng các tầng của mô hình TCP/IP,
mô hình OSI


A,Hãy viết tất cả câu lệnh cấu hình trên R2 đáp ứng yêu cầu mô hình trên. Vào RIP metric 10, vào
EIGRP 1000 10 255 255 1500
B, Hãy viết các câu lênh thực hiện cấu hình định tuyết trên R3.

- Định tuyến giao thức OSPF

A- Cấu hình ip cho các interface

N

.H

.P

Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#interface serial 2/0
R2config-if)#ip address 10.10.0.33 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#router ospf 45
R2(config-router)#network 10.10.10.32 0.0.0.3 area0
R2(config-router)#exit

- Quảng bá đường đi giữa các giao thức

N

A

O

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#redistribute ospf 45 metric 10
R2(config-router)#exit
R2(config)#router ospf 45
R2(config)#interface fastEthernet 0/0
R2(config-router)#default-information originate
R2(config-if)#ip address 172.16.5.1 255.255.255.128 R2(config-router)#redistribute rip subnets
R2(config-if)#no shutdown
B, Cấu hình định tuyết trên R3.
R2(config-if)#exit

Định tuyến giao thức Rip

R2(config)#interface serial 3/0
R2(config-if)#ip address 10.10.0.41 255.255.255.252
R2(config-if)#clock rate 2000000
R2(config-if)#no shutdown
R2(config-if)#exit

- Định tuyến giao thức Rip
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 172.16.5.0
R2(config-router)#network 10.10.10.40
R2(config-router)#no auto-summary
R2(config-router)#passive-interface fastEthernet 0/0
R2(config-router)#default-information originate
R2(config-router)#exit

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 10.10.10.40
R3(config-router)#no auto-summary
R3(config-router)#exit

- Định tuyến giao thức EIGRP và quảng bá
R3(config)#router eigrp 1000
R3(config-router)#network 172.16.5.160 0.0.0. 7
R3(config-router)#network 172.16.5.128 0.0.0.31
R3(config-router)#redistribute rip metric 1000 10
255 255 1500
R3(config-router)#no auto-summary
R3(config-router)#passive-interface fastEthernet 0/0
R3(config-router)#passive-interface Loopback 0
R3(config-router)#exit


A,Lập bảng xác định ĐC Ip của mỗi interface trên R1,R2,R3.
B, Hãy viết câu lệnh định tuyến trên R3
C, câu lệnh quảng bá đường đi giữa các giao thức trên R2 Vào RIP: Metric = 5 + Vào EIGRP: Sử dụng các giá trị
1000 10 100 100 1500

N

B, câu lệnh định tuyến trên R3

Ip address

R1serial 2/0

10.10.0.5

R1Lo0

172.16.25.65 255.255.255.240

R2serial 3/0

10.10.0.57 255.255.255.252

R2serial 2/0

10.10.0.6 255.255. 255. 252

R2Lo1

172.16.25.130 255.255.255.248

R2Lo2

172.15.25.192 255.255.255.248

R3serial 3/0

10.10.0.58 255.255.255.252

R3fastEthernet 1/0

172.16.25.97 255.255.255.248

255.255.255.252

N

Interface

A

O

.H

.P
A,Bảng địa chỉ IP của mỗi router

- Định tuyến giao thức EIGRP 1000
R3(config)#router eigrp 1000
R3(config-router)#network 10.10.0.56 0.0.0. 7
R3(config-router)#redistribute EIGRP 2000 metric
1000 10 100 100 1500
R3(config-router)#no auto-summary
R3(config-router)#exit
- Định tuyến giao thức EIGRP 2000
R3(config)#router eigrp 2000
R3(config-router)#network 172.16.25.96 0.0.0. 31
R3(config-router)#redistribute EIGRP 1000 metric
1000 10 100 100 1500
R3(config-router)#no auto-summary
R3(config-router)#passive-interface fastEthernet 1/0
R3(config-router)#exit

C, quảng bá đường đi giữa các giao thức trên R2
R2(config)#router eigrp 1000
R2(config-router)#redistribute ospf 10 metric 1000
10 100 100 1500
R2(config-router)#exit
R2(config)#router ospf 10
R2(config-router)#redistribute eigrp 1000 metric 5
subnets
R2(config-router)#exit


A,Lập bảng xác định ĐC Ip của mỗi interface trên R1,R2,R3.
B, Hãy viết câu lệnh cấu hình Default route và giao thức OSPF 45 trên R1
C, câu lệnh quảng bá đường đi giữa các giao thức trên R2 Vào RIP metric 10, vào
EIGRP 1000 10 255 255 1500

A,Bảng địa chỉ IP của mỗi router

.P

N

B,Default route và giao thức OSPF 45 trên R1

10.10.10.33 255.255.255.252

R1Lo1

10.10.10.2 255.255.255.252

R2serial 3/0

10.10.10.41 255.255.255.252

R2serial 2/0

10.10.10.34 255.255.255.252

R2fastEthernet 0/0

172.16.5.1 255.255.255.128

R3serial 2/0

10.10.10.42 255.255.255.252

R3fastEthernet 0/0

172.16.5.161 255.255.255.248

R3Lo0

172.16.5.129 255.255.255.224

Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#interface loopback 1
R1(config-if)#ip address 10.10.10.2 255.255.255.252
R1(config)#ip route 0.0.0.0 0.0.0.0 loopback 1
R1(config-router)#exit

A

Định tuyến giao thức OSPF

N

C, quảng bá đường đi giữa các giao thức trên R2
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#redistribute ospf 45 metric 10
R2(config-router)#default-information originate
R2(config-router)#exit
R2(config)#router ospf 45
R2(config-router)#default-information originate
R2(config-router)#redistribute rip subnets

O

.H

R1serial 2/0

R1(config)#router ospf 45
R1(config-router)#network 10.10.10.32 0.0.0.3 area 0
R1(config-router)#network 10.10.10.1 0.0.0.3 area 0
R1(config-router)#passive-interface loopback 1.
R1(config-router)#exit
D,quảng bá đường đi giữa các giao thức trên R3
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#redistribute static metric 10
R3(config-router)#redistribute eigrp 1000 metric 10
R3(config-router)#exit
R3(config)#router eigrp 1000
R4(config-router)#redistribute static metric 1000 10
255 255 1500
R3(config-router)#redistribute rip metric 1000 10 255
255 1500
R3(config-router)#exit


Thực hiện cấu hình giao thức định tuyến trên R1, R2 và R3. Thực hiện quảng bá giữa các giao thức tại R3.
vào EIGRP 1000 10 255 255 1500

*Định tuyến giao thức OSPF trên R1

N

R1(config)#router ospf 10
R1(config-router)#network 172.16.25.64 0.0.0.15
area 0
R1(config-router)#network 10.10.0.44 0.0.0.3 area 0
R1(config-router)#passive-interface Loopback 0

N

A

O

.H

.P

*Định tuyến các giao thức OSPF trên R2
R2(config)#router ospf 10
R2(config-router)#network 10.10.0.44 0.0.0.3 area 0
R2(config-router)#exit
*Định tuyến các giao thức EIGRP1000 trên R2
R2(config)#router eigrp 1000
R2(config-router)#network 10.10.0.56 0.0.0.3
R2(config-router)#network 172.16.25.0 0.0.0.63
R2(config-router)#no auto-summary
R2(config-router)#passive-interface fastEthernet 0/0
*Định tuyến các giao thức EIGRP1000 /2000 trên
R3
R3(config)#router eigrp 1000
R3(config-router)#network 10.10.0.56 0.0.0.3
R3(config-router)#no auto-summary
R3(config-router)#exit
R3(config)#router eigrp 2000
R3(config-router)#network 172.16.25.96 0.0.0.63
R3(config-router)#network 172.16.25.129 0.0.0.63
R3(config-router)#no auto-summary
R3(config-router)#passive-interface fastEthernet 0/0
R3(config-router)#passive-interface Loopback 1

*Quảng bá đường đi giữa các giao thức trên R3
R3(config)#router eigrp 1000
R3(config-router)#redistribute eigrp 2000 metric
1000 10 255 255 1500
R3(config-router)#redistribute static metric 1000 10
255 255 1500
R3(config-router)#exit
R3(config)#router eigrp 2000
R3(config-router)#redistribute eigrp 1000 metric
1000 10 255 255 1500
R3(config-router)#redistribute static metric 1000 10
255 255 1500
R3(config-router)#exit


Vào RIP metric 10, vào
EIGRP 1000 10 255 255 1500

A, Tất câu câu lệnh tại R1.

N

N

A

O

.H

.P

Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#interface loopback 1
R1(config-if)#ip address 10.10.10.2 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 2/0
R1(config-if)#ip address 10.10.10.33 255.255.255.252
R1(config-if)#clock rate 2000000
R1(config-if)#no shutdown
R1(config-router)#exit
R1(config)#router ospf 45
R1(config-router)#network 10.10.10.1 0.0.0.63 area 0
R1(config-router)#network 10.10.10.32 0.0.0.63 area 0
R1(config-router)#no auto-summary
R1(config-router)#passive-interface loopback 1
R1(config-router)#default-information originate
R1(config-router)#exit
R1(config)#router ospf 45
R1(config-router)#default-information originate
R1(config-router)#redistribute rip subnets

C, quảng bá đường đi giữa các giao thức trên R2
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#redistribute ospf 45 metric 10
R2(config-router)#default-information originate
R2(config-router)#exit
R2(config)#router ospf 45
R2(config-router)#default-information originate
R2(config-router)#redistribute rip subnets
D,quảng bá đường đi giữa các giao thức trên R3
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#redistribute static metric 10
R3(config-router)#redistribute eigrp 1000 metric
10
R3(config-router)#exit
R3(config)#router eigrp 1000
R4(config-router)#redistribute static metric 1000
10 255 255 1500
R3(config-router)#redistribute rip metric 1000 10
255 255 1500
R3(config-router)#exit


Cấu hình đầu đủ R3: Cấu hình ip cho các interface

interface
Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#interface loopback 0
R1(config-if)#ip address 192.168.1.1255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface loopback 1
R1(config-if)#ip address 192.168.4.33
255.255.255.224
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 2/0
R1(config-if)#ip address 10.10.0.5
255.255.255.252
R1(config-if)#clock rate 2000000
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#ip route 0.0.0.0 0.0.0.0 Loopback 1
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.4.32
R1(config-router)#network 10.10.0.4
R1(config-router)#passive-interface loopback 0
R1(config-router)#passive-interface loopback 1
R1(config-router)#no auto-summary
R1(config-router)#default-information originate
R1(config-router)#redistribute eigrp 20 metric 5
R1(config-router)#exit

R3(config-router)#network 10.1.0.12 0.0.0.3
R3(config-router)#redistribute static metric 1000 10 255
255 1500
R3(config-router)#redistribute ospf 1 metric 1000 10 255
255 1500
R3(config-router)#exit
EIGRP 1000 10 255 255 1500

N

R3(config)#router eigrp 20

A

O

.H

.P

N

Router>enable
Router#configure terminal
Router(config)#hostname R3
R3(config)#interface serial 3/0
R3(config-if)#ip address 10.1.0.13 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface fastEthernet 1/0
R3(config-if)#ip address 192.168.3.193 255.255.255.192
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface fastEthernet 0/0
R3(config-if)#ip address 192.168.3.65 255.255.255.240
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#router ospf 1
R3(config-router)#network 192.168.3.192 0.0.0.63 area 0
R3(config-router)#network 192.168.3.64 0.0.0.15 area 0
R3(config-router)#default-information originate
R3(config-router)#redistribute EIGRP 20 metric 5subnets
R3(config-router)#exit

Cấu hình đầu đủ R1: Cấu hình ip cho các


Cấu Hình Router

1>
Chuyển đổi chế độ.
Router>
Router>enable
Router#configure terminal
Router(config)#
2>
Tên và password
+> Router(config)#hostname (tên muốn đặt)
Tên(config)#
+> Router(config)#enable password (password muốn đặt)
3>
Đặt địa chỉ IP cho các cổng .
Router(config)#interface (tên cổng fa, ser, lookback)
Router(config-if)#ip address (địa chỉ IP host) (địa chỉ subnet mac)
Router(config-if)#clock rate 64000

Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#

N

A

5>
Cấu hình RIP 1.
Router(config)#router rip
Router(config-router)#version 1

O

.H

.P

N

4>
Định tuyến đường đi tĩnh .
** static route
Router(config)#ip route (đ/c IP mạng gián tiếp) (đ/c subnet) (tên cổng ra)
** default route
Router(config)#ip route 0.0.0.0 0.0.0.0 (tên cổng ra)
** kiểm tra
Router(config)#exit
Router#show ip route

Router(config-router)#network (đ/c mạng trực tiếp)

Router(config-router)#passive-interface (cổng Fa)

Router(config-router)#exit
6>
Cấu hình RIP 2.
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network (đ/c mạng trực tiếp)

Router(config-router)#no auto-summary
Router(config-router)#passive-interface (cổng Fa)

Router(config-router)#exit
Router(config)#
7>
Câu lệnh Kiểm tra
Router(config)#exit
Router# show ip route




Tài liệu bạn tìm kiếm đã sẵn sàng tải về

Tải bản đầy đủ ngay

×

×