Tải bản đầy đủ

ÔN TẬP CẤU HÌNH ĐỊNH TUYẾN Cau hinh dinh tuyen tinh

PHẦN 1. MÔ HÌNH CẤU HÌNH

Window XP là cloud1.
Management(Cloud0)-internet chinh là cloud0.
Management(Cloud0)-internet du phong là cloud0.
Trong unetlab thì muốn kết nối internet thì phải gắn cloud0.

PHẦN 2. YÊU CẦU CẤU HÌNH
Để làm được Lab này thì máy tính thật cần kết nối internet thành công.
Câu 1. Đặt IP cho mô hình. Chú ý là không đặt IP cho e0/2 của R2 và e0/2 của
R2. Vì các interface sẽ kết nối internet.
- Đặt IP cho R1.
Router(config)#hostname R1
R1(config)#interface ethernet 0/1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface ethernet 0/0
R1(config-if)#ip address 192.168.13.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 1/0
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
- Đặt IP cho R2.
Router(config)#hostname R2
R2(config)#interface serial 1/1
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit


R2(config)#interface ethernet 0/1
R2(config-if)#ip address 192.168.23.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
- Đặt IP cho R3.
Router(config)#hostname R3
R3(config)#interface ethernet 0/0
R3(config-if)#no shut
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface ethernet 0/1
R3(config-if)#ip address 192.168.23.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
- Đặt IP cho máy tính XP:
IP address:

192.168.1.10

Subnet mask:

255.255.2555.0

Default gateway: 192.168.1.1
DNS:

8.8.8.8

- Kiểm tra kết quả đặt IP:
+ Kiểm tra IP trên R1:
Chú ý là: R1 có 3 IP như trong hình bên dưới. Đảm bảo phải có 3 cặp up/up.

+ Kiểm tra IP trên R2:
Chú ý là: R2 được đặt 2 ip là 192.168.23.2 và 192.168.12.2. Ở đầu câu 1 yêu cầu không
đặt IP cho e0/2 nhưng do e0/2 của R2 kết nối vào cloud0, cloud0 chính là card NAT của
Vmware nên cloud0 sẽ cấp IP động là 192.168.75.130. Cấn chú ý IP cho e0/2 là khác
nhau theo từng máy tính.


+ Kiểm tra IP trên R3:
Chu ý là: R3 cũng tương tự R2 là chỉ đặt 2 IP là 192.168.13.3 và 192.168.23.3, còn e0/2
kết nối cloud0 nên được cấp IP động là 192.168.75.131.

- Trước khi cấu hình định tuyến tĩnh ở câu 2 thì kiểm tra bảng định tuyến của các Router
và đưa ra các nhận xét:
+ Bảng định tuyến của R1: L nghĩa là Local, C nghĩa là Connected. Vậy L và C có ý nghĩa
giống nhau. Chỉ cần quan sát chữ C là được. Vậy R1 có 3 chữ C: 192.168.1.0/24,
192.168.12.0/24, 192.168.13.0/4. Nếu quan sát lại mô hình mạng, trừ e0/2 của R2 và
e0/2 của R3 thì R1 còn thiếu 192.168.23.0.

+ Bảng định tuyến của R2: Giờ quan sát R2 sẽ thấy 2 chữ C là 192.168.12.0/24 và
192.168.23.0/24. Còn 1 chữ C là 192.168.75.0, chữ C này là do cloud0 cấp xuống theo


dạng định tuyến tĩnh nên ngoài C 192.168.75.0, còn có 192.168.75.0 là S. Còn dòng
S*0.0.0.0/0 được gọi là default route. Sẽ giải thích bên dưới.
Theo mô hình đã cho thì bảng định tuyến của R2 còn thiếu 192.168.13.0/24 và
192.168.1.0/24.

+ Bảng định tuyến của R3: tương tự ý nghĩa như R2.
Bảng định tuyến của R3 còn thiếu 192.168.12.0/24 và 192.168.1.0/24


Câu 2. Cấu hình định tuyến tĩnh sao cho đi từ máy tính XP sang
192.168.23.0/24 đi theo đường R1-R2 là đường chính. Còn đi theo đường R1-R3
là đường dự phòng.
Theo câu 1 thì:
- R1 còn thiếu 192.168.23.0.
- R2 còn thiếu 192.168.13.0/24 và 192.168.1.0/24.
- R3 còn thiếu 192.168.12.0/24 và 192.168.1.0/24.
- Do cần cấu hình đường đi chính và đường đi dự phòng nên cần chỉnh thêm giá trị AD.
+ Cấu hình định tuyến tĩnh trên R1:
R1(config)#ip route 192.168.23.0 255.255.255.0 192.168.12.2 10
R1(config)#ip route 192.168.23.0 255.255.255.0 192.168.13.3 20
Nhận xét: từ R1 đến 192.168.23.0 thì qua 192.168.12.2 là đường chín, nghĩa là đi theo
đường R1-R2 vì có AD là 10. Còn đi qua 192.168.13.3 là đường dự phòng vì có AD là 20.
+ Cấu hình định tuyến tĩnh trên R2:
R2(config)#ip route 192.168.13.0 255.255.255.0 192.168.12.1 10
R2(config)#ip route 192.168.1.0 255.255.255.0 192.168.12.1 10
R2(config)#ip route 192.168.13.0 255.255.255.0 192.168.23.3 20
R2(config)#ip route 192.168.1.0 255.255.255.0 192.168.23.3 20
Nhận xét: khi đi đến 192.168.23.0 thì theo R1-R2 là đường chính, thì gói tin trả về cũng
phải đi theo R2-R1 là đường chính nên R2 phải cấu hình cho 192.168.13.0 và 192.168.1.0
theo 192.168.12.1 có AD là 10. Tương tự vì R1-R3 là đường dự phòng nên R2 phải cấu
hình cho 192.168.13.0 và 192.168.1.0 theo 192.168.23.3 có AD là 10.
+ Cấu hình định tuyến tĩnh trên R3:
R3(config)#ip route 192.168.1.0 255.255.255.0 192.168.23.2 10
R3(config)#ip route 192.168.12.0 255.255.255.0 192.168.23.2 10


R3(config)#ip route 192.168.1.0 255.255.255.0 192.168.13.1 20
R3(config)#ip route 192.168.12.0 255.255.255.0 192.168.13.1 20
Nhận xét: Tương tự như R2.
- Kiểm tra lại bảng định tuyến của các router.
+ Bảng định tuyến của Router R1:


Chú ý cách đọc bảng định tuyến: nhìn vào dòng S 192.168.23.0/24 [10/0] via
192.168.12.2
 S là định tuyến tĩnh.
 192.168.23.0/24 là network cần đến.
 số 10 trong [10/0] là AD
 via có nghĩa là phải đi qua địa chỉ 192.168.12.2
+ Bảng định tuyến của Router R2:


+ Bảng định tuyến của R3:

- Kiểm tra kết quả cấu hình: từ window XP thực hiện lệnh như bên dưới.

Khi từ XP đến 192.168.23.3 thì đi theo 192.168.1.1 (R1), sau đó đến 192.168.12.2 (R2)
và cuối cùng là đến 192.168.23.3. Vậy R1-R2 là đường đi chính.
Câu 3. Cấu hình NAT trên R2 và R3 sao cho XP kết nối 8.8.8.8 theo R1-R2 là
đường chính còn R1-R3 là đường dự phòng.
- Quan sát lại bảng định tuyến của R2 có 1 dòng là: S* 0.0.0.0/0 [254/0] via
192.168.75.2. Dòng này được gọi là default route. Giờ sẽ giải thích default route là gì:
chú ý bên dưới là giải thích chứ không phải cấu hình. (nếu xem bảng định tuyến của R3
thì tương tự)
+ Giả sử trang zing.vn có IP là 3.3.3.3/24, vậy R1 muốn ping kết 3.3.3.3 thành công thì
trong bảng định tuyến của R1 phải có thêm dòng 3.3.3.0/24. Vậy chỉ cần cấu hình thêm
như sau:
R1(config)#ip route 3.3.3.0 255.255.255.0 192.168.12.2 10
R2(config)#ip route 3.3.3.0 255.255.255.0 192.168.13.3 20


Cấu hình như trên vì R1 đến 3.3.3.0 theo R1-R2 là đường chính, còn theo R1-R3 là đường
dự phòng.
+ (1) Vậy trên thế giới có rất nhiều trang web, mỗi trang web có 1địa chỉ, cấu hình như
vậy trên router sẽ mất rất nhiều công sức vì không thể nhập hết tất cả địa chỉ của tất cả
các trang web.
+ (2) Bảng định tuyến nằm trên RAM, nếu cứ thêm như vậy RAM sẽ hết mà cũng không
thể thêm hết tất cả các web site.
+ (3) Mạng của doanh nghiệp không thể định tuyến với nhà cung cấp dịch vụ được.
+ Vì (1), (2), (3) nên default route được sử dụng. Default route trên cisco có định dạng là
0.0.0.0 0.0.0.0 (hoặc 0.0.0.0/0), default sẽ đại diện cho tất cả các địa chỉ ngoài internet.
Vậy tại sao R2 và R3 chưa cấu hình default route nhưng trong bảng định tuyến đã có
default route. Vì các bạn dùng đồ ảo và R2, R3 gắn vào cloud0, cloud0 là vmnet 8 có
chức năng NAT internet. Do đó vmnet 8 sẽ cấp default route xuống. Trong thực thế thì
phải cấu hình default trên R2 và R3.
Vậy trong các bước cấu hình bên dưới, bước nào có sẵn thì mình sẽ ghi là KHÔNG CẦN
CẤU HÌNH, NHƯNG MÌNH VẪN SẼ GHI LỆNH CẤU HÌNH CHO CÁC BẠN. Còn bước nào
không ghi KHÔNG CẦN CẤU HÌNH thì các bạn phải cấu hình vào mô hình.
Bước 1. Cấu hình default trên R2 và R3. KHÔNG CẦN CẤU HÌNH. Vì cloud0 đã cấp xuống
rồi.
R2(config)#ip route 0.0.0.0 0.0.0.0 e0/2
R3(config)#ip route 0.0.0.0 0.0.0.0 e0/2
Bước 2. Từ R1 cấu hình default route về R2 và R3 với giá trị AD khác nhau để quyết định
đường đi chính và đường đi dự phòng.
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.12.2 10
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.13.2 20
Nhận xét: R1 default route về R2 có AD là 10, R1 default route về R3 có AD là 20.
Vậy R1-R2 là đường internet chính, còn R1-R3 là đường internet dự phòng.
Bước 3. Cấu hình NAT trên R2.
R2(config)#access-list 1 permit any
R2(config)#ip nat inside source list 1 interface ethernet 0/2 overload
R2(config)#interface ethernet 0/2
R2(config-if)#ip nat outside
R2(config-if)#exit


R2(config)#interface serial 1/1
R2(config-if)#ip nat inside
Bước 3. Cấu hình NAT trên R3.
R3(config)#access-list 1 permit any
R3(config)#ip nat inside source list 1 interface ethernet 0/2 overload
R3(config)#interface ethernet 0/2
R3(config-if)#ip nat outside
R3(config-if)#exit
R3(config)#interface ethernet 0/0
R3(config-if)#ip nat inside
Bước 4. Kiểm tra kết quả cấu hình.
Từ XP đi kết google 8.8.8.8 thì theo 192.168.12.2. Vậy R1-R2 là đường chính.

Câu 4. Lưu bài tập.
Bước 1. Lưu cấu hình trên Router

Bước 2. Chọn set nodes startup-cfg to exported từ hình bên dưới


Bước 3. Tiếp tục chọn Export all CFGs từ hình bên dưới

Bước 4. Tiếp tục chọn Stop all nodes từ hình bên dưới


Bước 5. Chọn Close Lab từ hình bên dưới là xong.

Bước 6. Export file bài tập ra lưu.

Bước 7. Chọn Ok. Bài tập sẽ được lưu thành 1 file .rar  XONG


BÀI TẬP.

Câu 1. Đặt IP.
Câu 2. Cấu hình sao cho từ XP  192.168.23.0/24 theo R1-R2 là đường chính.
Cấu hình sao cho từ XP  192.168.23.0/24 theo R1-R3 là đường dự phòng.
Câu 3. Cấu hình sao cho từ XP  8.8.8.8 theo R1-R2 là đường chính.
Cấu hình sao cho từ XP  8.8.8.8 theo R1-R3-R2 là đường dự phòng.



Tài liệu bạn tìm kiếm đã sẵn sàng tải về

Tải bản đầy đủ ngay

×

×